Adding a new IP for SSL

I created a domain for https.
Webmin - Networking - Network Configuration - Network Interfaces

Activated at boot:
Name Type IPv4 address Netmask IPv6 address Activate
eth0 Ethernet x.x.x.50 255.255.255.248 No
eth0:1 Ethernet (Virtual) x.x.x.51 255.255.255.248 No
eth0:2 Ethernet (Virtual) x.x.x.52 255.255.255.248 No
eth0:3 Ethernet (Virtual) x.x.x.53 255.255.255.248 No
eth0:4 Ethernet (Virtual) x.x.x.54 255.255.255.248 No
eth1 Ethernet 10.224.70.130 255.255.255.224 No
lo Loopback 127.0.0.1 255.0.0.0
Yes

Active now: all UP

x.x.x.50 is the regular ip for http
x.x.x.51 and 52 are for name servers

I want x.x.x.54 for https

When I go to Virtualmin - MyDomain - Change IP Address:
Current IP x.x.x.50
New IP has drop down menu with only one item: x.x.x.50

What can I do?
Thank you
M

I deleted the virtual server and started again. There’s an option to input the desired IP.
Now it seems to work. I was able to set new certificate and key and enter https successfully.
Curiously, from the same network pinging from one computer (Ubuntu) to mail server shows the new IP while from other (Mac) returns the old one

Howdy,

The best way to do that for an existing Virtual Server, is to go into Server Configuration -> Change IP Address, and to select a “Private IP Address”. And then, in that blank text box, input the IP you’d like to use.

The IP in the dropdown box are the available shared IP’s… you typically wouldn’t use that for SSL certificates, you’d want a private IP, just for that one domain.

-Eric