Abnormality with created email addresses

OS type and version Ubuntu 20.04
Webmin version 2.021
Virtualmin version 7.7

Hello there theres is a problem with email addresses/users that are created in virtualmin. For example if domain is abcd.com the emails adresses/user created appears as name.abcd when it should normally be name@abcd.com. Refer to the image for more details

How can this be fixed?

That is odd I have just tried to create a user (same OS and versions, .com domain) no problems
My first thought was that you might have entered the username incorrectly so I tried nam.domain.com but even that was processed correctly to name.domain.com@domain.com

Makes me wonder if there are any log entries worth looking for?

It looks very much like a virtual server administration user. and I thought they were only created when adding a new virtual server

You need to look at the template and set up it up so the user is created in the x@y format and not the user.domain format a few years ago the x@y format did not exist which did make it difficult for non techs to set up email clients

1 Like

Hi Jimr1, thanks for your response. I do not understand what template you are reffering to. Could you please tell me more information. will appreciate it

Hi thanks for your response. Perharps i will try to reinstall the script and see if that issues clears

go to

vmin->system settings->server templates

choose the required template, maybe the default one unless you have modified it.
then from the drop down choose mail for domain and scroll to the bottom and you will see

just change the arrowed line to user@domain from user.domain and save the template. this will apply the required format of email address to all new users but NOT existing ones to switch the existing users over it may be the case of deleting the user and recreating them. You can transfer the email addresses over to the new format but to be fair it is out of the scope of vmin as it done via the command line

1 Like

@jimr1 That is very useful to know. But it would be nice to know if? or how? the original template had been altered.

I was under the impression (perhaps wrongly) that this was a newish vanilla install and in that case only having the default unaltered template. If it has been altered or another template used then this acts as a warning that making such a change is a pretty critical move and perhaps needs a “are you sure” prompt!


Thank you so much for helping me resolve the issue. I did as you said and discovered that username.domain.com was the default option so i changed it username@domain.com and now i have proper email addresses and i am able to login to Roundcube without any problem.

Thanks for your help!!!

1 Like

I have not had vanilla server for ages but when i did the user name was always in the form user.domain i changed to user@domain a couple of years ago and never gave it another thought

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.