A domain name cannot start with *

Failed to create virtual server : A domain name cannot start with *. To create a wildcard domain, first create it without the * and then go to Server Configuration → Website Options.

but where is Server Configuration?

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.6
Webmin version 2.105
Virtualmin version 7.9.0

Virtualmin -> Web Configuration -> Website Options

it moved! (but wildcards are not recommended)

Sorry, but where do I setup the wildcard?

also why wildcards aren’t recommended?

I just saw “Website matches all subdomains”! Silly me, that’s maybe the one!

But same options didn’t exist for alias server. (u.itsrinaldo.net is an alias of u.rinaldo.id).
Will setting u.rinaldo.id be enough to include *.u.itsrinaldo.net?

I think this applies specifically to ssl cert requests. I have never had the need to enable this so cannot know if they are linked - if you do enable it check the Lets Encrypt tab that it doesn’t include wildcard certs.

ouch … thanks for the response.
I think I’ll pass the SSL to cloudflare to handle it later …

maybe starting my own bitly-like with codes in subdomains *.u.rinaldo.id was a bad idea lol

Thanks, we will fix it!

But some of us have got used to it!

Change is good (keeps one awake at night) :laughing:

oh god, so many things are THAT different lol

last time I use virtualmin was 2012, using CentOS 5, while I was still at junior high school, learning how to manage my wordpress blog all by myself, using 128MB RAM, 1 core, and literally begging my parents to pay the VPS bill. LOL

this panel brings memories … and headache LOL.

but thanks for staying around!