554 Relay access denied

Ok, I know this is a common problem, and I know that it is nothing to do with Virtualmin, but I thought some in the forum might have a solution to this error or maybe there is a setting in virtualmin that will do what I need.

I have changed the message to hide the name and email address of the person it was being sent to.

I guess I don’t fully understand relaying. Since I thought relaying was when someone used your mail server to send mail to another server.

The problem I am seeing is that if a user is offsite, on another network, and they try to send email they get the message below. Now this person is a user on the system, and they are using mail.whateverdomain.com to send the mail. So why can’t they send the mail? Yes, if the user changes their smtp setting to be that of their ISP mail server, they can send mail, but what about laptop users, they should be allowed to send mail using the mail server for their domain without having to memorize all the smtp servers for all the possible netoworks they might encounter. Shouldnt they?

Is there a simple way to tell the mail server to only allow people that authenticate as actual users with the proper email address to send mail instead of not allowing them to send mail based on what network they are on?

this is the message I get. I seen a couple of options in the postfix section of webmin, but I dont feel comfortable making changes to something that I apparently dont understand.

any ideas?

Your message did not reach some or all of the intended recipients.

  Subject:   Tshirt Screen Printing Prices

  Sent:     10/24/2006 12:30 PM

The following recipient(s) could not be reached:

  persons name (email@msn.com) on 10/24/2006 12:30 PM

        554[email@msn.com>: Relay access denied

Hey William,

Your users need to enable SMTP authentication in their mail client, and provide their username and password.

There is no other safe way to open up relaying for folks outside of your network (OK, relay-after-POP also works, but it’s very clumsy and prone to user complaints because it often fails to work as they expect or when they expect it to…so we’ve never bothered to add support for it, and no one has ever asked for it).

How you enable it depends on the mail client. In Thunderbird the options are in the Outgoing SMTP server configuration window.

Ya, thats what I thought, in fact the domain that I moved over to the virtualmin server, some of the users has that box checked, I was one of them, and my mail always worked fine, but after the move to the virtualmin server, it would pop up and ask for my password again, its like it wasnt configured in virtualmin somewhere. So I unchecked it and sending and receiving worked fine, I rechecked it and it would complain about the password again or username.