550 Hostname Rejected in some mails hosts from my server...

Hi I have a GPL virtualmin version installed on my server, I have only a IP asigned, and I have 3 mail domains in the server…

the hostname server is: admin.sysvirtuales.com and I have a reverse dns record for this host.

my problem is that some mail host (for example xalingo.com.br) give me a 550 error (hostname rejected), I created a SPF record on my dns server for the domain to solve this, but the problem still do it,

I need help to fix this, are the any solution for this… any help is apreciated…


Hmm, I don’t see anything in particular wrong with your hostname or IP address. It’s not listed on any common black lists or RBL’s.

What is the full error message you get when a server rejects your email?


Hi the domain that have the problem is int-rosenberg.net (when I send mails to xalingo.com.br I see the error) , the error says:

From: “Mail Delivery System” MAILER-DAEMON@admin.sysvirtuales.comTo: analucia@int-rosenberg.netSent: Wednesday, March 16, 2011 8:11 AMSubject: Undelivered Mail Returned to Sender > This is the mail system at host admin.sysvirtuales.com.>> I’m sorry to have to inform you that your message could not> be delivered to one or more recipients. It’s attached below.>> For further assistance, please send mail to >> If you do so, please include this problem report. You can> delete your own text from the attached returned message.>> The mail system>> adriano@xalingo.com.br: host a.mx.xalingo.com.br[] said: 550> Hostname rejected. (in reply to RCPT TO command)>

(this the complete mail)

My real problem is that my domain (int-rosenberg.net) in your last server can sent mails to this domain, and on my server not.


What Linux distribution are you using?

And what output do you receive if you run “postconf -n”?


Ok the version is CentOS Linux 5.5
the kernel version is Linux 2.6.18-028stab070.3 on i686

the “postconf -n” says:

> postconf -n alias_database = hash:/etc/aliases alias_maps = hash:/etc/aliases broken_sasl_auth_clients = yes command_directory = /usr/sbin config_directory = /etc/postfix daemon_directory = /usr/libexec/postfix debug_peer_level = 2 home_mailbox = Maildir/ html_directory = no inet_interfaces = all mail_owner = postfix mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME mailq_path = /usr/bin/mailq.postfix manpage_directory = /usr/share/man maximal_backoff_time = 2000s maximal_queue_lifetime = 120m minimal_backoff_time = 500s mydestination = $myhostname, localhost.$mydomain, localhost, admin.sysvirtuales.com newaliases_path = /usr/bin/newaliases.postfix queue_directory = /var/spool/postfix queue_run_delay = 500s readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES sample_directory = /usr/share/doc/postfix-2.3.3/samples sender_bcc_maps = hash:/etc/postfix/bcc sendmail_path = /usr/sbin/sendmail.postfix setgid_group = postdrop smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination smtpd_sasl_auth_enable = yes smtpd_sasl_security_options = noanonymous unknown_local_recipient_reject_code = 550 virtual_alias_maps = hash:/etc/postfix/virtual

I have some more problem too much mails (from my own domain) are marked as SPAM…

Okay, I don’t see anything particularly unusual there…

What if you type the command “hostname”, what output do you receive?



Hrm, are you having problems sending mail to any other hosts?

I’m not sure that anything stands out as being a problem… your hostname looks correct. You have reverse DNS setup for your hostname. Your Postfix settings look good. And the “From” address of the email, “int-rosenberg.net”, has both forward and reverse DNS.

It’s possible the problem is with the remote server, and not with you… is it possible to contact them (via phone perhaps) and ask their sysadmin why they’re rejecting your email?


I have the same problem…every mail from my own domain is going in spam :frowning:

Try inputting your server’s IP address at this URL here:


That will check to see if your server is listed on any RBL’s, which could explain why your email is being classified as spam.