502 Bad Gateway - Recent Domain transfer

Hi there,

I am here again with another issue, I recently transfer a site to a new domain service and created the domain in virtualmin, uploaded the files and imported the SQL, this is a wordpress installation.

I am getting this 502 error… I already added and tried different ways like

location / { try_files $uri $uri/ /index.php?q=$uri&$args;

That supposedly prevents several of these errors and others around the net and here in the forums but still the same.

Using Nginx, Centos 6.5, MySQL

Features and plugins enabled:

Mail for domain
Log file rotation
Spam filtering and Virus
Webmin Login
Nginx SSL Website (not applied to the virtual server)
Nginx website

Hope any one can give me a hand with this… Thank you!


I’m not too familiar with Nginx, but you may want to review the error logs for that particular domain to see if they offer more information.

There’s some information here on what can cause that problem:


The example that stood out to me is the possibility that Nginx might be configured to proxy requests to Apache.