500 error on all scripts

I’m still thinking that this problem is related to suexec (I believe suexec only comes into play when fcgid or cgi mode are chosen) but troubleshooting suexec seems to be quite difficult… I spent several hours today searching on google and trying all kinds of stuff…
Is there any way to remove or eliminate suexec from the proces? And maybe just test a php file with php in fcgid mode but without suexec?
Or any tips on troubleshooting or testing suexec?

Well, still no solution. cgi or fcgi modes are still not working…
I’m under a bit of time pressure here as I have to move my website to this server very soon… (or I will have to pay another year at my old host)
With mod_php everything works as it should so what are the consequences of leaving it at that? Is the fcgi setup with suexec mainly a security measure to protect server owner against virtual server owners? Or is it more than that? In any case, all virtual servers are owned by me and I’m the only one who has access to the server (and the virtual servers) and I think I can trust myself… Or are there any other security risks by using mod_php?

Yeah, I’m kind of stuck as to what the issue you’re seeing is… but you’re correct that the FCGID+suexecc system is largely for security across a shared hosting server.

For just one user – there’s not the same sort of benefit, and mod_php should work just fine.


Ok! Thanks for your replies and for trying to help.