404 Not Found after webmin update


I have a dedicated server (ubuntu 12.04 LTS) and I have installed virtualmin+webmin to manage it,

I have created a virtual server named “applications” in order to install scripts such as phpmyadmin or roundcube.

I used to connect to these two application by using the links:
http://server IP/phpmyadmin or http://server IP/roundcube

after an update of the ubuntu server (some webmin update + some security update) I couldn’t access to phpmyadmin nor roundcube anymore! I get the following error 404 Not Found The requested URL /phpmyadmin/ was not found on this server.

I removed ubuntu 12.04 and installed 14.04 and re installed virtualmin+webmin and did the same thing with my “applications” virtual host, but I still get the same error.

Can you please help me with this probleme


You may just be seeing an issue with an Ubuntu default VirtualHost taking precedence over your existing domains.

If you look in /etc/apache2/sites-enabled, do you see a “000-default” file in there? You should be able to just delete that, and restart Apache.

After doing that, are you then able to access your domains?


thank you for your kind reply,
as a matter of fact i had the 000-default in the sites enabled and I have deleted it and restarted apache, however that did’t seem to solve the probleme,

In the other hand i have noticed something very funny and strange, apparently the problem is not related to the update but :
At first I had a virtual host named named “application” where I had my centralized phpmyadmin and roundcube.
all the other virtual servers had names that came after “Application” (like Cxxxxxx.com , Oxxxxxxx.com) in the alphabetic order.
when I have added a virtual host with the name Accountingxxxx.com it becamed first of the list.
and this is what caused my problem.
Now I have deleted “Application” and created a new virtual host named “AAA” and it is anow the first in the list, after adding the phpmyadmin script and roundcube script, everything works as normal.

So this means that may be the server takes the aliases from the first virtual host in the list?

any way thank you again for your reply, I just wanted to leave the solution I found for other persons to read.

Your virtualmin could be dead after update so just try to start/restart it: /etc/init.d/webmin restart