404 error on alias to a virtual server


I’m a first time Virtualmin user, though not a technical newbie.

I’ve had quite a few problems getting up and running, but I’ll keep this post to the most current issue.

I created a virtual server called businessgrowthadviser.co.uk.

Because I’m not ready to move the live www. site across, I created an alias called portal.businessgrowthadviser.co.uk and added an appropriate A record to the DNS zone.

I uploaded a file to /home/businessgrowthadviser/public_html/phpinfo.php, containing…

<?php phpinfo(); ?>

But I get a 404 error when I visit http://portal.businessgrowthadviser.co.uk/phpinfo.php.

What do I need to adjust to make it work?

Thanks for your help.

Kind regards


===== UPDATE =====

I deleted the alias server in Virtualmin and set ‘Server Configuration >> Website Options >> Website matches all sub-domains?’ to Yes for the virtual server.

I still get the 404 error on http://portal.businessgrowthadviser.co.uk/phpinfo.php.

I’m sure I’ve overlooked something trivial!

===== UPDATE 2 =====

I found some useful info. at https://www.virtualmin.com/documentation/web/troubleshooting.

The issue for me is that I’m on an Amazon EC2 Instance and had set ‘System Settings >> Virtualmin Configuration >> Network Settings >> Default virtual server IP address’ to the public IP address.

It worked as soon as I changed it to ‘From network interface’. :slight_smile:

Hope this helps someone else.


I’m always available to assist new folks who are just getting started with Virtualmin. For a FREE consult, simply send me an email or message me on Skype to setup some time.

Best Regards, Peter Knowles TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-229-0715 (new)
Skype: tpnsupport
Website: http://www.tpnsolutions.com