403 Forbidden after restore to Ubuntu 14.04 from Ubuntu 12.04


I created new VPS with Ubuntu 14.04 and fresh Virtualmin install.
All went great.
Then I restored virtual server from Virtualmin from Ubuntu 12.04 to the latest Ubuntu server.
Now I receive error 403 Forbidden.

I found a tip http://www.virtualmin.com/node/33473 to go to system settings > server templates > apache website change here : allow from all to : Require all granted.

I did, on two places.

The same problem.

Any ideas?


That “Require all granted” will indeed help with new Virtual Servers, but you may need to set that for your existing ones.

That is, you may need to go into /etc/apache2/sites-enabled/, and edit your various .conf files in there to add that line.

Alternatively, you could always go into Edit Virtual Server -> Enabled Features, find the Apache Website feature, and then disable it, and then enable it, which will re-generate the Apache config using what’s in the Server Template.


Glad I found this. I just migrated from 12.04 to 14.04 as well and noticed the same issue. Couldn’t figure it out. Tried the disable and enable on one and it worked. I don’t have a ton of web sites but still annoying to do it to 8 of them (subdomans) be worse for people with a lot more. Would be nice if there was a fix included on the restore. I followed the virtualmin migrate page.